Opened 10 years ago

Closed 10 years ago

#1965 closed Bug (fixed)

SpellerPages crashes IE 7

Reported by: Thomas Messier Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6
Component: UI : Spell Checker Version: FCKeditor 2.6 Beta
Keywords: Confirmed IE Review+ Cc:

Description

When I run spell check using SpellerPages IE crashes (always). Basically, I run a spellcheck and once I get the popup that the spellcheck is complete, I click on the OK button and that's when the crash occurs. I'm using Windows XP SP2 and my IE version is 7.0.5730.11.

Attachments (1)

1965.patch (1.4 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Wojciech Olchawa

Component: GeneralUI : Spell Checker
Keywords: Confirmed IE added

Confirmed in IE7. FF2 doesn't seem to be effected by this bug. As IE7 crashes I'm getting this report:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	iexplore.exe
  Application Version:	7.0.6000.16609
  Application Timestamp:	47575b9a
  Fault Module Name:	mshtml.dll
  Fault Module Version:	7.0.6000.16609
  Fault Module Timestamp:	4757754f
  Exception Code:	c0000005
  Exception Offset:	0009378d
  OS Version:	6.0.6000.2.0.0.256.6
  Locale ID:	1045
  Additional Information 1:	8d13
  Additional Information 2:	cdca9b1d21d12b77d84f02df48e34311
  Additional Information 3:	8d13
  Additional Information 4:	cdca9b1d21d12b77d84f02df48e34311

The bug also occurs in IE6, but in this case the browser just freezes and refuses o respond.

comment:2 Changed 10 years ago by Nader

This may be related to another case: http://dev.fckeditor.net/ticket/1934 The 2nd patch: http://dev.fckeditor.net/attachment/ticket/1934/1934_2.patch which was not part of the downloaded package I got resolved a similar issue in Ie6 where the browser crashes after the spellCheck dialog self-closes.

comment:3 Changed 10 years ago by Thomas Messier

I tested the patch from the comment above to see if it would solve the problem and it doesn't.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6

I'm have no problems with IE7. With IE6 instead, I' having an Access Denied error. So, something is definitely wrong here.

Much probably it depends on selection related things, because of the new dialog system.

comment:5 Changed 10 years ago by Nader

I believe the Access Denied error may be related to the mixed-mode warning in IE6 when using "javascript:void(0)" as the source of an iFrame. If I remember correctly from when I got around this issue a week or so ago -- the script attempts to access the contents of an iFrame set to "javascript:void(0)" while the security dialog is still just about to be displayed. This was occurring for me on a SSL server. Try changing the iframe within the spellCheck dialog file to a "blank.html" file and see if it works.

Most of the iframes needed to be converted to reference a "blank.html" as on SSL servers and Ie, you get mixed-mode warnings for using "javascript:void(0)"

I was able to get around both issues, the spellCheck works fine in Ie6/7 and FF2 in the modified copy I have.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1965.patch added

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Owner: set to Frederico Caldeira Knabben
Status: newassigned

It seems that the OnSelectionChange event firing was entering in concurrence with something else at the end of the spell checking process, probably with the SetData function.

The proposed patch simply delays the event firing execution. No more errors have been thrown in this way, and there should be no penalty to the rest of the code because of it.

comment:7 in reply to:  5 Changed 10 years ago by Frederico Caldeira Knabben

Replying to naderf:

Most of the iframes needed to be converted to reference a "blank.html" as on SSL servers and Ie, you get mixed-mode warnings for using "javascript:void(0)"

Fortunately we have fixed all HTTPS issues without having to use an empty page. It is just a matter of using the right URL for it, which is different for each browser. Check out the FCKTools.GetVoidUrl() function definition in the fcktools.js file.

Btw, the proposed patch has been checked over HTTPS with no warnings.

comment:8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

I guess that this one should be OK for the moment, but we must remember it for the V3 event handling

also there are some spelling mistakes: cuncurrency vs concurrency and "t obe" vs "to be"

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1777]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy