Ticket #201 (closed Bug: fixed)

Opened 7 years ago

Last modified 7 years ago

HR in input "source" completely destroys document structure

Reported by: amashtakov@… Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.3.2
Keywords: SF IE Confirmed Cc: geotronik@…

Description

Hi all,

This can be easyly re-produced in current demo page (2.3.1). Please try the following:

  1. Create three <p>'s with bold title an text in editor view:
<p><strong>title1<br />
</strong>text1 text1</p>
<p><strong>title2</strong><br />
text2 text2</p>
<p><strong>title3<br />
</strong>text3 text3</p>
<p>&nbsp;</p>
  1. Then put <hr>'s at the beginning of title2 and title3 in editor view:
<p><strong>title1<br />
</strong>text1 text1</p>
<p><strong><hr />
title2</strong><br />
text2 text2</p>
<p><strong><hr />
title3<br />
</strong>text3 text3</p>
<p>&nbsp;</p>
  1. Then switch twice between source and editor view. As a result - the structure of document is completely destroyed:
<p><strong>title1<br />
</strong>text1 text1</p>
<p><strong></strong><br />
text2 text2
<p>&nbsp;</p>
<p><strong></strong>text3 text3
<p>&nbsp;</p>
<p>&nbsp;</p>
</p>
<hr />
title3<br />
</p>
<hr />
title2

Regards, /Alexander


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1552552&group_id=75348&atid=543653

Change History

comment:1 Changed 7 years ago by fredck

  • Keywords IE added

missed browser info - IE6.0


Moved from SF. Original poster: amashtakov

comment:2 Changed 7 years ago by fredck

I changed the FCKConfig.UseBROnCarriageReturn to true. It says that attribute is IE only but see it working on FF. Recently, when i discovered this problem and started playing with configuration settings, i tried this issue on the demo site (2.3.2 in this case) and as you say, it failed. But now, the demo site has obviously made this same change, because no more <p></p> are present in new content using your example. the CR is <BR> and not <P> even in the demo. It has solved the issue for me. My clients were reporting things "hopping around" after saving content.

See what it does for you.

Eric


Moved from SF. Original poster: geotronik

comment:3 Changed 7 years ago by fredck

  • Cc geotronik@… added
  • Reporter changed from fredck to amashtakov@…

comment:4 Changed 7 years ago by fredck

  • Keywords Confirmed added

Confirmed with IE6. Firefox is OK.

The <hr> is a block tag, which inside another block tags (<p>) makes IE go crazy.

comment:5 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Resolution set to duplicate

This is a DUP of #202.

comment:6 in reply to: ↑ description Changed 7 years ago by walkingstick

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I am still seeing nearly identical behavior in IE 7.0 with build 2.4.1. Following steps 1 and 2 above results in the following code:

<p><strong>title1<br />
</strong>text1 text1</p>
<p><br />
text2 text2</p>
<p>&nbsp;</p>
<p>text3 text3</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<hr />
<p>title3</p>
<p>&nbsp;</p>
<hr />
<p>title2</p>

I saw that this was said to be fixed in 2.4 but it does not appear to be.

comment:7 Changed 7 years ago by fredck

  • Status changed from reopened to closed
  • Resolution set to duplicate

It was an unfortunate regression brought with [219]. It regressed [202] too, so this one is still a DUP of it.

I've fixed it with [321].

comment:8 in reply to: ↑ description Changed 7 years ago by walkingstick

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I do not wish to be a pain about this, but I am still seeing the same behavior. I copied your new code over the old in fck.js and tested it, but still get the same results.

If I paste this code in the source view of the editor (using IE 7.0):

<p><strong>title1<br />
</strong>text1 text1</p>
<p><strong><hr />
title2</strong><br />
text2 text2</p>
<p><strong><hr />
title3<br />
</strong>text3 text3</p>
<p>&nbsp;</p>

And then switch to the main view I see the text as it should be.

But then if I switch back to source mode the text code gets jumbled to look like this:

<p><strong>title1<br />
</strong>text1 text1</p>
<p><br />
text2 text2
<p>&nbsp;</p>
<p>text3 text3
<p>&nbsp;</p>
<p>&nbsp;</p>
</p>
<hr />
title3<br />
</p>
<hr />
title2

comment:9 Changed 7 years ago by alfonsoml

I've tested the nightly build and it works fine for me in IE6 and IE7

comment:10 follow-up: ↓ 11 Changed 7 years ago by fredck

  • Status changed from reopened to closed
  • Resolution set to fixed

It works for me too with the SVN version. Please download the entire SVN version for testings.

comment:11 in reply to: ↑ 10 Changed 7 years ago by walkingstick

Replying to fredck:

It works for me too with the SVN version. Please download the entire SVN version for testings.

Ok. I downloaded and installed the entire SVN version and it worked. Thanks for the quick response on this.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy