Opened 10 years ago

Closed 10 years ago

#2011 closed Bug (fixed)

<LINK> tags for internal CSS files are appearing in full page mode

Reported by: Martin Kou Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

This is a very serious bug which is making the full page mode unusable. To reproduce the bug:

  1. Open sample07.html in any browser.
  2. Switch to Source mode.
  3. You'll see fck_internal.css being included inside the full page XHTML source.
  4. Switch to WYSIWYG mode and back to Source mode.
  5. You'll see the <LINK> tag(s) used for including our internal CSS files are being duplicated!

The issue did not exist in 2.5.1 or any 2.6 code before the floating dialog branch merge. So some changes in between must have caused this bug.

Attachments (1)

2011.patch (1.2 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Martin Kou

Priority: NormalHigh

comment:2 Changed 10 years ago by Martin Kou

The bug is found to be caused by [1598].

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Owner: changed from Martin Kou to Frederico Caldeira Knabben
Status: newassigned

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 2011.patch added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Review? added

A recursive call was not sending all parameters.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1717]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy