Opened 10 years ago

Closed 6 years ago

#2013 closed Bug (worksforme)

Nested lists inherit their parents attributes (including id)

Reported by: simonbun Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: FCKeditor 2.6 RC
Keywords: Cc: fck@…

Description

Best explained with an example:

<ul id="foo" class="bar">
  <li>Item1</li>
  <li>Item2</li>
</ul>

When increasing the indent on Item2 so it becomes a sublist of Item1, it somehow inherits the original list's id & class...like so:

<ul id="foo" class="bar">
  <li>Item1
    <ul id="foo" class="bar">
      <li>Item2</li>
    </ul>
  </li>
</ul>

Which is pretty bad, especially for the id.

On a related note: adding an item to the list below causes the item's class to be copied. In this case the id is not copied, luckily.

<ul>
  <li id="foo" class="bar">Item1</li>
</ul>
<ul>
  <li id="foo" class="bar">Item1</li>
  <li class="bar">Item2</li>
</ul>

I'm not sure I understand the reasoning behind copying attributes of parents / siblings. It seems to me that it should at least be configurable behavior. Then again, there might be a catch that I'm missing.

regards, Simon

Change History (3)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added; nested attributes class id removed
Version: FCKeditor 2.6 RC

Confirmed using 2.6 RC both on IE and FF3.

comment:2 Changed 10 years ago by Wojciech Olchawa

sorry should be FF2 not FF3.

comment:3 Changed 6 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy