Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#203 closed Bug (worksforme)

Instert Template FireFox

Reported by: sstraakenbroek@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: WorksForMe Pending Cc:

Description

When you have a big template file (23000 characters) and you want too insert that template, I get an unresposive script error with FireFox 2.0.0.2. This goes both bad on Windows and Mac with FireFox. With IE it goes without any problem.

Attachments (3)

template.html (31.1 KB) - added by sstraakenbroek@… 13 years ago.
Template
screenshot.jpg (41.7 KB) - added by sstraakenbroek@… 13 years ago.
Error screenshot
fcktemplates.xml (31.2 KB) - added by Frederico Caldeira Knabben 13 years ago.
Test Case Template defintion file

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by Frederico Caldeira Knabben

Can you attach the template to this ticket?

Changed 13 years ago by sstraakenbroek@…

Attachment: template.html added

Template

Changed 13 years ago by sstraakenbroek@…

Attachment: screenshot.jpg added

Error screenshot

comment:2 Changed 13 years ago by sstraakenbroek@…

After some testing around i found out that it goes bad on the following onclick function:

FCK.SetHTML

Changed 13 years ago by Frederico Caldeira Knabben

Attachment: fcktemplates.xml added

Test Case Template defintion file

comment:3 Changed 13 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending added

I've just attached a test template definition file with your template. Just overwrite it in the FCKeditor directory.

It worked perfectly for me. The template insertion is almost immediate.

Do you have good results with it? If yes, please attach your XML file to this ticket. I believe there is something wrong there.

comment:4 Changed 13 years ago by sstraakenbroek@…

Thanx for the template. I replaced it with the one i had but i still get an warning: unresponsive script on firefox.

If i uncheck the option: replace current content. Then it goes without any problem.

comment:5 Changed 13 years ago by sstraakenbroek@…

I download a version of FCKeditor and put it on the server and tested it with you templates.xml and there i didn't get any error. So there must be something i did wrong while updating the fckeditor version.

Gonna do search differences.

comment:6 Changed 13 years ago by sstraakenbroek@…

Ok, i think i know where the problem is.

When you are testing with a default FCKeditor version everything goes OK.

BUT if you are using full page editing. Then it goes wrong when inserting an template. Tested this on the clean version of FCKeditor with the option full page editing.

comment:7 Changed 12 years ago by Alfonso Martínez de Lizarrondo

I've tried that template with Firefox 2.0.0.3 Windows, using the current trunk of the Editor and sample 7 to use full page editing and didn't get any error.

I've tried both inserting or replacing the content and everything went fine.

comment:8 Changed 12 years ago by YellowMind

With the newest version of FCKeditor is works perfect here. Don't know what it was but it works now.

comment:9 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy