Opened 9 years ago

Closed 9 years ago

#2042 closed Bug (fixed)

Executing the FitWindow command from the shortcut without a button raises an error

Reported by: Alfonso Martínez de Lizarrondo Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6
Component: UI : Toolbar Version: FCKeditor 2.5
Keywords: Confirmed Review+ Cc:

Description

load sample09, put the focus in the first editor and press the Ctrl+Alt+Enter combo to execute the FitWindow command, an error is generated (it doesn't matter the browser):

this._UIButton has no properties
File: editor/_source/classes/fcktoolbarbutton.js
Line: 55

Attachments (1)

2042.patch (1.5 KB) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: FCKeditor 2.6
Owner: set to Frederico Caldeira Knabben
Status: newassigned

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 2042.patch added

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added

It happened because the FitWindow button is not present in the toolbar. The proposed patch should fix it.

comment:3 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1778]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy