Opened 11 years ago

Closed 11 years ago

#2067 closed Bug (invalid)

Lose content with IE 6 & 7

Reported by: DELBOSC Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Cc:

Description

Here is what I am using:

  • Fckeditor module for Drupal: 5.x-2.x-dev
  • Fckeditor: 2.5.1


And here is my problem:

  • With Internet Explorer 6 & 7 when I enter some text in the fckeditor and then do some clicks on the page, the content of the fckeditor is cleared.
  • One way I have to reproduce the bug is to enter the text, let the focus inside the fckeditor, maximize/minimize a fieldset and then click on a blank part of the page (outside the fckeditor).
  • Another one is to enter the text, let the focus inside the fckeditor, use the vertical scrollbar and then click on any blank space outside the fckeditor.


With Firefox all of this works well. The main difference seems to be that each time you click outside the fckeditor the focus is lost by the fckeditor.

I’ve tried the 5.x-2.1 release of the Drupal module and it’s the same thing.

Does anyone have already encountered this kind of bug?

Attachments (1)

FCKeditor_content_lost.zip (116.3 KB) - added by DELBOSC 11 years ago.
A video file showing how to reproduce the bug

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: IE6 IE7 removed
Resolution: invalid
Status: newclosed

It seems that this is a Drupal site problem, not a problem with FCKeditor itself, so I'm closing this ticket. Please report this bug at http://drupal.org/ page.

Thanks

Changed 11 years ago by DELBOSC

Attachment: FCKeditor_content_lost.zip added

A video file showing how to reproduce the bug

comment:2 in reply to:  1 Changed 11 years ago by DELBOSC

Resolution: invalid
Status: closedreopened

Replying to w.olchawa:

It seems that this is a Drupal site problem, not a problem with FCKeditor itself, so I'm closing this ticket. Please report this bug at http://drupal.org/ page.

Thanks

Thank you for your answer. I'm still wondering how you can be sure that it's Drupal related.

Moreover, I have a more accurate way of reproducing the bug. It will maybe help you to better understand my problem. The bug happens only one there is only one line in the Fckeditor with no linefeed at the end.

I've attached a video file showing how to reproduce the bug. Please have a look at it and tell me your opinion about this.

Thanks in advance.

comment:3 Changed 11 years ago by DELBOSC

We have recently found that it may be due to some CSS properties. One thing is sure, it's not related to FCKeditor tool. You can thus close this ticket.

When I am sure about the root cause, I'll update this post.

Really sorry for the inconvenience.

comment:4 Changed 11 years ago by Wojciech Olchawa

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy