Opened 12 years ago

Closed 8 years ago

#2093 closed Bug (worksforme)

Inconsistent ability to remove basic styles depending on selection

Reported by: Lebannen Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.6 RC
Keywords: Cc: julia.frigiere@…

Description

To reproduce the problem:

1) Go to http://www.fckeditor.net/demo 2) Select the words "This is some", and apply the style "Red Title". The entire sentence gains the styled h3 block element. 3) Try to remove the style. The style cannot be removed. 4) Select the entire sentence. Try to remove the style. The style cannot be removed. 5) Click inside the title to place the editing caret inside the element, with no selection. Try to remove the style by clicking on "Red Title" again. The red colour style is removed.

This is linked to #2092 - currently it is not possible to change the block element (in this case h3), but the removal of the associated style="color: red;" should be consistent across partial selection, full selection, and no-selection-but-caret-inside.

I would suggest that all three actions should allow what the caret-inside action currently does.

(Occurs in 2.5.1, 2.6 RC)

Change History (4)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added; styles removed
Version: FCKeditor 2.6 RC

Confirmed using IE and FF2.

comment:2 Changed 11 years ago by Julia

Cc: julia.frigiere@… added

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

#2362 has been marked as DUP

comment:4 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy