Opened 11 years ago

Closed 11 years ago

#2117 closed Bug (fixed)

File browser does not work under domain relaxation mode

Reported by: Wiktor Walc Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.2
Component: File Browser Version: FCKeditor 2.6
Keywords: Confirmed Review- Cc:

Description

I've created separate ticket, because it's probably a different issue than #1919.

  1. Open _sample01.html in domain relaxation mode under Firefox 2.0.0.13.
  2. Open the image dialog.
  3. Click "Browser Server".

Even if there are images in the folder, they are not displayed. In frmresourceslist.html there is an empty body

<body class="FileArea"/>

although GetFoldersAndFiles has been called succesfully.

Attachments (1)

2117.patch (2.2 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Wiktor Walc

Keywords: Confirmed added

comment:2 Changed 11 years ago by Martin Kou

The problem occurs in the php sample as well.

comment:3 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:4 Changed 11 years ago by Martin Kou

It seems to work in Firefox 3 RC2, IE6 and Safari 3.1. Seems like a FF2 specific problem.

Domain relaxation breaks Opera 9.50 now :(.

Changed 11 years ago by Martin Kou

Attachment: 2117.patch added

comment:5 Changed 11 years ago by Martin Kou

Keywords: Review? added

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

I'm not able to reproduce this problem with the current trunk. The list of files correctly display, using FF2. Can anyone else confirm it?

There is another bug instead with domain relaxation. When clicking on one of the images in the File Browser, a "Permission denied" error is thrown and the image URL is not returned to the image dialog. Applying the patch doesn't get it fixed though.

comment:7 Changed 11 years ago by Martin Kou

The "Permission denied" error with the image URLs are caused by the fix to #2115... which also magically "fixes" this ticket.

But the #2115 fix actually disabled the domain relaxation logic in the file browser HTMLs and so it is actually causing other problems, such as the one you just see. I've filed the new issues to #2296. The patch to #2296 should be applied in conjunction to my patch to get a fully working image dialog.

comment:8 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Ok... the problem reported in this ticket has been fixed with [2059], which introduced other issues, but have nothing to do with this ticket (see #2296).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy