Opened 10 years ago

Closed 10 years ago

#2126 closed Bug (fixed)

[IE] Dialogs break toolbar button states

Reported by: Mark Bryson Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.1
Component: General Version: FCKeditor 2.6
Keywords: Confirmed IE Review+ Cc:

Description

State of the cut/copy buttons doesn't work properly after a positive response (OK button) to a dialog. It can be corrected by invoking a dialog and then pressing 'Cancel'. State can also be temporarily corrected by right clicking along with the proper states of the context menu, but still won't continue to work properly until canceling a dialog.

This was not a problem with 2.6 beta (build 18219).

Problem noted with IE7. Not a problem with FF 2.0.0.13.

Attachments (1)

2126.patch (1.2 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Milestone: FCKeditor 2.6.1
Summary: Dialogs break cut/copy button states[IE] Dialogs break cut/copy button states
Version: SVNFCKeditor 2.6

Confirmed using FCKeditor 2.6 and the current SVN version. Browsers affected: IE6 and IE7. Works OK with FF2.

Minimum steps to reproduce:

1. Insert a table

2. Write some text any ware in the editor

3. Highlight the text

The Cut and Copy buttons are disabled.

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.1

#2165 has been marked as dup.

The bug affects all the toolbar buttons, the Selection Change event doesn't seems to be fired.

comment:3 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Summary: [IE] Dialogs break cut/copy button states[IE] Dialogs break toolbar button states

comment:4 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Another regression of [1818] is explained in http://dev.fckeditor.net/ticket/2125#comment:4 Now the selection isn't properly restored unless the dialog is focused.

Changed 10 years ago by Martin Kou

Attachment: 2126.patch added

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review? added

comment:7 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed
Resolution: fixed
Status: assignedclosed

Fixed with [1971].

Click here for more info about our SVN system.

(the Review+ was from Fred in the IRC channel)

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy