Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#213 closed Bug (fixed)

Enter key does not preserve formatting between paragraphs

Reported by: mkoepke@… Owned by:
Priority: Normal Milestone: FCKeditor 2.4.3
Component: UI : Enter Key Version: FCKeditor 2.4
Keywords: Confirmed SD-COE Cc: pkdille, Jean-Marc Libs, Nyloth

Description

  1. Select a text size (small in this)
  2. Type 'This is a test'
  3. Press Enter key
  4. Type 'to see if this works'

Upon the second paragraph the size selection gets lost. Below is the source this was created from above: <p><font size="3">This is a test</font></p> <p>to see if this works<font size="3"></font></p>

One note is that upon entering the second paragraph, the Size combo goes blank and the Format combo becomes Normal.

IMHO if the user manually selects a size it should have persistance until changed again.

Change History (8)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added

Confirmed with both IE6 and FF2.

To note that with the SVN version, empty <font> tags are not anymore generated, but the visual result is the same as reported.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [207].

Click here for more info about our SVN system.

comment:3 Changed 10 years ago by Chris Oh

Resolution: fixed
Status: closedreopened

This issue is not fixed in IE6 or IE7! Installed the fix 207. Pressing the Enter key will always change the font face and size.

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

It does work fine for me.

Please provide detailed steps to reproduce the bug using the nightly version: http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

comment:5 in reply to:  3 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed

Replying to chrisoh:

This issue is not fixed in IE6 or IE7! Installed the fix 207. Pressing the Enter key will always change the font face and size.

It works for me too. Please reopen this ticket only in case the issue is still reproducible in the nightly build.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Cc: Pascal.KUSTNER@… added
Keywords: SD-COE added

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Cc: jean-marc.libs@… patrice.weber@… added

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Cc: pkdille Jean-Marc Libs Nyloth added; Pascal.KUSTNER@… jean-marc.libs@… patrice.weber@… removed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy