Opened 11 years ago

Closed 11 years ago

#2210 closed Bug (wontfix)

[FF] font-weight: bold and font-style:italic instead of strong and em

Reported by: shala Owned by:
Priority: Normal Milestone: FCKeditor 2.6.1
Component: Core : Styles Version: FCKeditor 2.6
Keywords: Confirmed Firefox CantFix Cc:

Description

Hello,

There is a bug with Firefox when doing some manipulations on bold and italic.

Let's try this with the demo FCK on the website :)

1/ Type "Hello world"
2/ Make the characters "rld" in bold

In Source view, we'll have something like <p>hello wo<strong>rld</strong></p>

3/ Now we delete the substring "orld" and then retype orld

In source view : <p>hello w<span style="font-weight: bold;">orld</span></p>

We have the same kind of bug with the italic button Tested on FF 2.0.0.14 and FF 3RC1 with FCK 2.6

Change History (3)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed Firefox added
Version: FCKeditor 2.6

Confirmed using FCKeditor 2.6 and the latest SVN in Firefox. Doesn't seem to be an issue in IE.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6.1

Wow... this one sounds like an ugly "automagication" of Firefox, which would be quite hard for us to fix. We need a ticket for it at their Bugzilla.

Targeting it to the 2.6.1 to ensure we have that ticket, but it's likely to be closed with a sad CantFix at our side.

comment:3 Changed 11 years ago by Martin Kou

Keywords: CantFix added
Resolution: wontfix
Status: newclosed

I've reported the bug to https://bugzilla.mozilla.org/show_bug.cgi?id=435709.

Since the <span> tag was generated by Midas automatically, there's very little we can do at this stage. Closing ticket as CantFix.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy