Opened 11 years ago

Closed 11 years ago

#2261 closed Bug (fixed)

[IE] @import in EditorAreaCss causes a javascript error in source view

Reported by: nina Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc:

Description

I am having a similar problem as described here: http://www.fckeditor.net/forums/viewtopic.php?f=6&t=9345&p=24267&hilit=editorareacss+import#p24267

But my problem is a little bit different.
In my fckconfig.js I set the

FCKConfig.EditorAreaCSS = 'mystyles.css' ;

then in mystyles.css I have the lines:

@import "/includes/css/main.css"; 
@import "/includes/css/foo.css"; 
@import "/includes/css/bar.css"; 

html, body {
	text-align: left;
	background-color: white;
	font-size: 12px;
}

I do this because I have 3 css files I want my editor area to show up like. Once I do this, when I bring up my page that has the fckeditor textarea on it, I will do this:

  1. click in the textarea - the menu does not pop down - like it should.
  2. manually put the menu down
  3. click source button.
  4. don't make any changes and just click ok on the source popup window (yes i have my source set to pop up)
  5. you get a javascript error that says:

Permission denied fckeditor.html?InstanceName=[mytextarea name]&ToolBar=Basic

If I remove the @imports out of my mystyles.css file, it will work fine.

I also downloaded the nightly build for fckeditor on 6/8/2008 and tried reproducing this bug on that nightly build version too, and the bug is still there.

Please notify me once this is fixed so I can upgrade. For now, I'm sticking to 2.4.2 until this is resolved.

Thanks so much!!! -NS

Change History (6)

comment:1 in reply to:  description Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Milestone: FCKeditor 2.6.1
Summary: editorareacss that points to a css file with an @import gives javascript error on view source[IE] @import in EditorAreaCss causes a javascript error in source view
Version: SVN

Replying to ns123:

  1. click in the textarea - the menu does not pop down - like it should.
  2. manually put the menu down

To reproduce this bug you may open any dropdown menu.

Confirmed in IE. FF works as expected.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6.2

This looks like a serious issue. I'm targeting to the 2.6.2 for investigation.

comment:3 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:4 Changed 11 years ago by Martin Kou

This seems to be caused by the same bug in #2135, maybe #2135's patch can fix this as well.

comment:5 Changed 11 years ago by Martin Kou

I can get a JavaScript error in IE6 with telesto's test case in #2135 by clicking on the Source button a few times, but the error I get isn't exactly the same as yours.

Is it possible for us to have a test case that could exactly replicate your errors?

comment:6 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

I've done some tests again and couldn't get any errors. I believe this ticket has been fixed by the patch to #2135.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy