Opened 12 years ago

Closed 11 years ago

#229 closed Bug (worksforme)

Safari: Dragging links appends style attribute to <a>

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone: Safari Compatibility
Component: General Version:
Keywords: Cc:

Description

When dragging a linked text, the following attribute is appended to the <a> element:

style="color: rgb(0, 0, 255) -webkit-text-decorations-in-effect: underline; "

Change History (5)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

This problem seems to be fixed in the webkit nightly.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

In my tests, the nightly and Safari 3 Beta now adds the following to the <a>:

style="color: rgb(0, 0, 255) !important; "

It doesn't happen to Safari 3 for Windows, so it seams to be OS dependent.

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

More info... it happens only when selecting "text + link", like "You are using <a href="http://www.fckeditor.net">FCKeditor</a>.". If you double click the link, it is dragged as an object instead, and no styles are appended to it.

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

I'm not able to reproduce it anymore with Safari 3.0.4 (Mac and Win).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy