Opened 9 years ago

Closed 9 years ago

#2323 closed Bug (fixed)

Show blocks command scrolls selection out of visible area.

Reported by: Martin Kou Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

To reproduce the bug:

  1. Open sample01.html in any supported browser.
  2. In source mode or WYSIWYG mode, copy the given paragraph a few hundred times so that the whole document is scrollable.
  3. Scroll to the middle of the document, select one of the "sample text" in one of those middle paragraphs.
  4. Press "Show Blocks".
  5. The selected text is scrolled out of the visible view pane.

Attachments (1)

2323.patch (2.0 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Martin Kou

Attachment: 2323.patch added

comment:1 Changed 9 years ago by Martin Kou

Keywords: Review? added

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [2142].

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: closedreopened

Please ignore my last comments... #2321 has been fixed actually.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

I'm giving a Review+ to this one, because it makes it work a bit better. But I don't see this as the definitive solution for it.

I think the right solution would be leaving the element which is currently at the top boundary of the window still there after the user action. The selection should not be used for that because I could still scroll the page, moving the selection out of the visible space and then hit "Show Blocks"... it will give you the strange effect of scrolling to the selection.

As the right solution looks like something difficult to achieve, let's go ahead with this intermediary solution. We could think on a better option in the future.

comment:5 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: reopenedclosed

Fixed with [2144].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy