Opened 11 years ago

Closed 11 years ago

#2370 closed Bug (fixed)

MediaWiki 1.13 + FCKeditor - Image button search and preview not working

Reported by: tybeede Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: fixed Cc:

Description

Hello folks,

I think this is a bug. I've got the latest release of all the software downloaded from SVN as of 7/15/08. This includes MediaWiki and FCK extension with FCK editor.

I can upload an image file via mediawiki upload and everything works great. The filename gets added to the database and shows up when you click on the "list uploaded files". I can add the image to a wiki page using both the wiki markup lang and the image button.

However, when using the image button I am unable to get any search results or a preview of the image. If I type the name correctly I can insert the image and it shows up like normal. However, I don't get a search result or a preview at any point. After the image is inserted into the page I can right click and edit the image. In this case the preview does pop up in the dialog box.

I followed the install guide at the Mediawiki + FCK editor integration site and everything else works great.

Attachments (2)

2370.patch (931 bytes) - added by Artur Formella 11 years ago.
2370_2.patch (1.9 KB) - added by Artur Formella 11 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by tybeede

Component: GeneralProject : MediaWiki+FCKeditor

comment:2 Changed 11 years ago by tybeede

Version: SVN

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

I was unable to reproduce your bug using MW 1.13 and the latest FCKeditor SVN extension. Searching as well as previewing works as expected in IE (6&7) and in FF(2&3). Could you please let us know what browser are you using? Could you also update to the latest version and let us know if the bug still occurs?

Thanks in advance.

Changed 11 years ago by Artur Formella

Attachment: 2370.patch added

comment:4 Changed 11 years ago by Artur Formella

Keywords: Confirmed Review? added; Pending WorksForMe removed

I think it's connected with mysql LOWER() which are ineffective when applied to binary strings (BINARY, VARBINARY, BLOB)

comment:5 in reply to:  4 Changed 11 years ago by mrw

arczi's fix works, the bug also affected file searches for me. However, the new patch is indiscriminate with numbers, searching for 53 brings up 55 55 and so on.

comment:6 Changed 11 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

This fix isn't PostgreSQL compatible.

@mrw: what files exactly do you have there and what are you searching for? I'm asking because "53" is too short.

Changed 11 years ago by Artur Formella

Attachment: 2370_2.patch added

comment:7 Changed 11 years ago by Artur Formella

Keywords: Review? added; Review- removed

comment:8 Changed 11 years ago by Wiktor Walc

Looks good, but when an image is found and selected, it isn't displayed in the editor. This is probably due to a bug introduced in #2223.

When [[Image:FooBar.jpg]] is parsed and changed into image tag to get link to a real image using src attribute:

$originalLink = $parser->parse("[[Image:".$term."]]", $wgTitle, $options)->getText();
if (false == strpos($originalLink, "src=\"")) {
	return "";
}

$srcPart = substr($originalLink, strpos($originalLink, "src=")+ 5);

we don't get there an <img> tag but a link. So if #2223 will be fixed, this ticket can be reviewed properly.

comment:9 Changed 11 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

comment:10 Changed 11 years ago by Artur Formella

Keywords: fixed added; Confirmed Review+ removed
Resolution: fixed
Status: newclosed

Fixed with [2467]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy