Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#251 closed Bug (duplicate)

Inconsistent Tab behavior

Reported by: Mike Koepke Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Cc:

Description

The Tab key doesn't seem to behave as expected. In FF it moves the text 2 characters. In IE, the Tab key actually cycles between the web page elements and has no effect in the editor itself.

With FF 2.0.0.2

  1. Go to http://www.fckeditor.net/nightly/fckeditor/_samples/default.html
  2. Create a second line of text underneath "This is some sample text. You are using FCKeditor." with 1234567890
  3. Cursor to beginning of "This is some sample text. You are using FCKeditor."
  4. Press Tab key. The line "This is some sample text. You are using FCKeditor." shifts to right 2 spaces to position above '3' in second line.
  5. Source does reveal "<p>&nbsp;&nbsp;&nbsp; This..."

With IE 7.0

  1. Go to http://www.fckeditor.net/nightly/fckeditor/_samples/default.html
  2. Cursor to beginning of "This is some sample text. You are using FCKeditor."
  3. Press Tab Key. Cursor moves to Submit button
  4. Pressing Tab again cursor cycles to next html element on sample page and so on

Additionally with FF, the FCKConfig.TabSpaces setting seems to be ignored. I duplicated the above behavior with 2.4.0 on my site. The above behavior has FCKConfig.TabSpaces = 0;. Setting FCKConfig.TabSpaces = 8; makes no difference. You still get "<p>&nbsp;&nbsp;&nbsp; This..."

Change History (2)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: FCKeditor 2.5

Confirmed with FF2 and IE6.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5
Resolution: duplicate
Status: newclosed

Actually this is a DUP of #137.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy