Opened 11 years ago

Closed 8 years ago

#2547 closed Bug (invalid)

Mediawiki and <pre> tags with FCKeditor

Reported by: CKL Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Confirmed Cc:

Description

Hi

It seems that there is again a bug with <pre> tag in mediawiki Test

At http://mediawiki.fckeditor.net/index.php/Sandbox

enter the following text, then switch several times between wikitext

<pre> 
Hello Wiki User 
Hello Wiki User 
Hello Wiki User 
</pre> 
<pre>
Bonjour Utilisateur Wiki
Bonjour Utilisateur Wiki
Bonjour Utilisateur Wiki 
Bonjour Utilisateur Wiki 
</pre>

Change History (7)

comment:1 Changed 11 years ago by Artur Formella

Component: GeneralProject : MediaWiki+FCKeditor
Keywords: <pre> removed

comment:2 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

comment:3 Changed 11 years ago by CKL

Hello

have you some news regarding this issue.

Thanks a lot

Christian

comment:4 Changed 11 years ago by Mitul

I am facing the same issue. The issue is generated when two pre tag are posted and both are one after one. like

<pre>
Test
test
</pre>
<pre>
test2
test3
test333
</pre>

To resolved the issue I have did some changes in FCKeditorParser.body.php at following location and it works for me.

Change Line No: 568 From

if ( !$this->mInPre ) {

To

if ( !$this->mInPre || ($preCloseMatch==1 && $preOpenMatch==1) ) {

Add Code after Line No: 642 or after this code block

if ( $preOpenMatch and !$preCloseMatch ) {
	$this->mInPre = true;
}

Add This code block

if ( $preOpenMatch and $preCloseMatch ) {
	$this->mInPre = true;
}

Change Line No: 688 From

if($preCloseMatch && $this->mInPre) {

To

if($preCloseMatch && $this->mInPre && !$preOpenMatch) {

May this help

Regards Mitul

comment:5 Changed 11 years ago by Mitul

Resolution: fixed
Status: newclosed

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: closedreopened

The ticket is supposed to be closed only when the SVN code get fixed. Thanks for your suggestions though.

comment:7 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: reopenedclosed

MediaWiki and FCKEditor are no longer supported. Closing the ticked as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy