Opened 11 years ago

Last modified 7 years ago

#2568 confirmed Bug

Adding Cell Background color adds unwanted space in the table

Reported by: Mark Buckallew Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.0
Keywords: Cc:

Description

When merging a row, adding text to the merged row and the next row, then selecting a background color for all cells in rows 1 and 2, an unwanted space is added above and below the second row. This occurs on IE 7 and windows.

Steps: 1 - Open the FCK Editor with a Full toolbar 2 - Insert a table of 3 columns and 3 rows 3 - Merge the three cells in the top row (right-click and select Merge Right), so there is a single row on top

[ ] [ | | ] [ | | ]

4 - Type values in the the first and second row (a total of 4 cells) 5 - Highlight the first and second rows, right click and select Cell/Properties 6 - Set a background color

Expected: Rows 1 and 2 would have the background color set Observed: Rows 1 and 2 have the background color set, but empty cells are created over the 2nd and 3rd cells in the second row

I checked the demo site and it is still an issue there.

Attachments (2)

FCKEditor Adding Background color.JPG (85.4 KB) - added by Mark Buckallew 11 years ago.
zrzut_ekranu-13.png (39.2 KB) - added by Krzysztof Studnik 8 years ago.
JS error while trying to reproduce under CKE3.6.1

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by Mark Buckallew

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Priority: HighNormal

Confirmed on IE7, FF3 (vista32).

<table cellspacing="1" cellpadding="1" width="200" border="1">
    <tbody>
        <tr>
            <td colspan="3">This is a test</td>
        </tr>
        <tr>
            <td>This</td>
            <td>is</td>
            <td>a test</td>
        </tr>
        <tr>
            <td>&nbsp;</td>
            <td>&nbsp;</td>
            <td>&nbsp;</td>
        </tr>
    </tbody>
</table>

After step 5 and 6:

<table cellspacing="1" cellpadding="1" border="1" width="200">
    <tbody>
        <tr>
            <td bgcolor="#660066" colspan="3">This is a test</td>
        </tr>
        <tr>
            <td bgcolor="#660066" colspan="3">This</td>
            <td bgcolor="#660066" colspan="3">is</td>
            <td bgcolor="#660066" colspan="3">a test</td>
        </tr>
        <tr>
            <td>&nbsp;</td>
            <td>&nbsp;</td>
            <td>&nbsp;</td>
        </tr>
    </tbody>
</table>

On Safari bug does not occur because it's impossible to "select" more than 1 cell. It is not a critical bug so I change priority to Normal.

comment:2 Changed 11 years ago by Artur Formella

Version: FCKeditor 2.6

comment:3 Changed 11 years ago by Alfonso Martínez de Lizarrondo

@arczi: why have you deleted the version field?

Maybe it's present in older builds and the 2.6 isn't exact (in that case you can set it to 2.5 or 2.3 or whatever fits), but removing the 2.6 data is removing info, specially if someone tests and sees that it isn't present for example in 2.5 then we can find the changeset that introduced the bug, and that way it will be easier to fix it.

The version field should contain the oldest version where we know that the problem exist. For example bumping from 2.6 to SVN is useless, all the bugs are present in SVN by their own definition, if it's fixed in SVN then the bug should be closed as fixed. SVN bugs are just the bugs that have been introduced since the latest release. I guess that this bug didn't exist for example in 2.3 because a lot has been changed related to styles and tables, so finding the regression range will help fixing it, and having at least 2.6 as a version means that we should look at any build newer than 2.6.

comment:4 Changed 11 years ago by Artur Formella

Version: FCKeditor 2.3.2

Sorry for that. I have deleted the version field because the bug exists in all versions. I have tested 2.0 - 2.6.3.

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

The fact is that "all" dialog properties are being applied to the cells, not only the background color. As we have "Rows Span" and "Columns Span" in the dialog, those are also set to all selected cells, bringing that buggy effect (which is not a bug, considering the way the dialog has been developed).

A possible fix for it would be changing the dialog system in a way that it applies only the changed fields. It means we should also have some visual states in the fields to indicated that they are have not being changed (and therefore will not be applied). We're not likely to have such huge change that soon though.

Changed 8 years ago by Krzysztof Studnik

Attachment: zrzut_ekranu-13.png added

JS error while trying to reproduce under CKE3.6.1

comment:6 Changed 7 years ago by Jakub Ś

Component: GeneralCore : Tables
Version: FCKeditor 2.3.23.0

3.6.2 also has this problem

comment:7 Changed 7 years ago by Jakub Ś

This ticket is reproducible in all browsers but only IE browsers throw error:

Message: Object does not support this property or method „data”
Line: 131
URI: _source/plugins/elementspath/element.js

Issue with JS error was described in #8400

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:8 Changed 7 years ago by Jakub Ś

Cells in second row all get colspan 3 instead if colspan 1

Last edited 7 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy