Opened 11 years ago

Closed 8 years ago

#2619 closed Bug (worksforme)

Making a link on text containing a <sup> tag results in link being split

Reported by: Thomas Tallyce Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: Safari Cc:

Description

If I have some HTML like

<p>the size is 4m<sup>2</sup>.</p>

and in the visual editor mode I highlight this and make a link, the HTML becomes:

<p><a href="link.html">the size is 4m</a><sup><a href="link.html">2</a></sup><a href="link.html">.</a></p>

rather than

<p><a href="link.html">the size is 4m<sup>2</sup>.</a></p>

The first is not sensible as this means there are now three tab entries and the link is not treated as a single link.

Change History (2)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed Safari added; sup link removed
Milestone: Safari Compatibility
Version: FCKeditor 2.6FCKeditor 2.4

Confirmed in Safari3.1 (Vista32). In FF and IE works fine.

comment:2 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy