Ticket #2624 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Editing article in Wiki with rich editor resets images

Reported by: scott_harman Owned by:
Priority: High Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc: normalex@…

Description

Running latest FCKeditor inside MediaWiki extension Editing existing documents removes the image tag [[Image:image1.JPG]] becomes [[Image:]]

Change History

comment:1 Changed 5 years ago by arczi

  • Keywords Pending WorksForMe added

comment:2 Changed 5 years ago by scott_harman

running with MediaWiki 1.12.0 - also occurs regardless of framing and alignment options

comment:3 Changed 5 years ago by scott_harman

Comment on discussion page on mediawiki: http://www.mediawiki.org/wiki/Extension_talk:FCKeditor_(by_FCKeditor_and_Wikia)#Image_WYSIWYG_Incorrect.3F

<quote>

Mediawiki 1.12 uses a new wysiwyg to display images on page, <nowiki> {{ns:image}}:File.jpg?</nowiki>.

FCKEditor still uses the old technique, <nowiki>[[image:file.jpg]]</nowiki> that just directly links to file. any updates for this?

Update: FCKEditor will corrupt the coding of this new image convention when switching between wikitext and FCK.

Update: I figured maybe I could change the coding in extensions\FCKeditor\plugins\mediawiki\fckplugin.js to push the new convention but nothing changed. Renaming the file itself also revealed no change. Where is the formatting for image coding being done? </quote>

comment:4 Changed 5 years ago by arczi

I don't understand. [[Image:image1.JPG]] isn't changed, {{ns:image}}:File.jpg? too. How it should work?

comment:5 Changed 5 years ago by normalex

  • Priority changed from Normal to High

Confirm this bug in Mediawiki 1.13.2 and FCKeditor 2.5.1 When you change mode to Wikitext and then back to normal, all Image tags become to just [[Image:]]

comment:6 Changed 5 years ago by normalex

  • Cc normalex@… added

Found cause of it. It is usage of tidy in mediawiki. when you have installed and enabled "$wgUseTidy = true" it will eventually reset all Image tags on a page. Tested it on Mediawiki 1.11.2, 1.13.2 and 1.13.3 with FCKEditor 2.6.2 and 2.6.3

comment:7 Changed 5 years ago by wwalc

I cannot reproduce it using the latest SVN version of FCKeditor extension with MW 1.13.5 and 1.14.0 ($wgUseTidy = true), could you confirm that this issue is solved?

comment:8 follow-up: ↓ 9 Changed 5 years ago by Leapfrog

I can confirm that it solved the issue for me running turnkey-mediawiki-2009.04-hardy-x86.iso

thanx allot :)

comment:9 in reply to: ↑ 8 Changed 5 years ago by arczi

  • Keywords Pending WorksForMe removed
  • Status changed from new to closed
  • Resolution set to fixed

Replying to Leapfrog:

I can confirm that it solved the issue for me running turnkey-mediawiki-2009.04-hardy-x86.iso

Ok. let's close this ticket as fixed. Feel free to reopen if you have such problems with the current version.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy