Ticket #2626 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

problem with Skin::setupUserCss in Mediawiki 1.13+

Reported by: candrews Owned by: arczi
Priority: High Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Review+ Cc:

Description

I just installed MediaWiki+FCKeditor and FCKeditor (both from trunk) on my trunk installation of mediawiki (1.14 rev 42659 right now).

When I try to use FCKeditor by going to any edit page, I get this error: {{{PHP Catchable fatal error: Argument 1 passed to Skin::setupUserCss() must be an instance of OutputPage, none given, called in /var/www/wiki-server/w/extensions/FCKeditor/FCKeditor.body.php on line 341 and defined in /var/www/wiki-server/w/includes/Skin.php on line 546, referer: https://wiki.molecular.com/wiki/Main_Page}}

Attachments

2626.patch (518 bytes) - added by arczi 5 years ago.

Change History

comment:1 Changed 5 years ago by candrews

  • Summary changed from problem with Skin::setupUserCss in Mediawiki 1.14 to problem with Skin::setupUserCss in Mediawiki 1.13+

I just found this issue documented here: http://www.mediawiki.org/wiki/Extension:FCKeditor_(by_FCKeditor_and_Wikia)#Manual_modifications_.28only_for_1.13_users.29

So this is actually 1.13+ issue, not just 1.14.

Can this be fixed in your trunk, so fckEditor works "out of the box" on the latest version of mediawiki?

comment:2 Changed 5 years ago by arczi

  • Keywords Confirmed added
  • Priority changed from Normal to High

comment:3 Changed 5 years ago by arczi

  • Owner set to arczi
  • Status changed from new to assigned

Changed 5 years ago by arczi

comment:4 Changed 5 years ago by arczi

  • Keywords Review? added

Tested in MW 1.1, 1.3 and phase3-r43286 (FF and IE).

comment:5 Changed 5 years ago by G.Hagedorn

I still fail to install the FCK integration with the current version of Mediawiki, even though above the bug is claimed to be patched: "2626.patch added". Or is this patch not in the subversion repository? I tested it yesterday with the newest SVN checkouts of MediaWiki, FCK integration and fckeditor, and obtained the same error reported here. Further reports of the same error are:

comment:6 Changed 5 years ago by arczi

It's true. This patch is not committed. It is waiting for test by community and review by developers. To test you have to add it by yourself.

comment:7 Changed 5 years ago by G.Hagedorn

I have manually added the code to our installation, and FCKeditor starts and works.

Note: I find it confusing, to provide subversion and then do not use it for development and testing. Several users from the community have tried to install it, and could have tested it. You are providing static stable downloads, so on subversion I would expect a day-current version, ready for community testing. Perhaps you could create a trunk and stable in subversion? Or does this exist, but difficult to find?

The problem is lack of responsiveness. On Mediawiki errors are fixed, committed and tested within minutes. Fixing within a week would be very satisfactorily for FCKeditor, but here it seems to be months (FCK seems to have been non-functional since Mediawiki 1.13, that is since 2008-03-20 ...)

comment:8 Changed 5 years ago by candrews

I've been using this patch for 2+ months, and it's working. Can this get applied to SVN?

comment:9 Changed 5 years ago by wwalc

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [3177].

comment:10 Changed 5 years ago by wwalc

  • Keywords Review+ added; Confirmed Review? removed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy