Opened 10 years ago

Closed 7 years ago

#2646 closed Bug (wontfix)

regex to test image (file) extensions is incorrect

Reported by: lamer j Owned by:
Priority: Low Milestone:
Component: General Version: FCKeditor 2.4
Keywords: Cc:

Description

  • /fckeditor/fckconfig.js line 301, 306, and 311 all have incorrect regex for extensions (maybe should check elsewhere).

I have only tested 306 which fails to work properly at /fckeditor/editor/dialog/fck_image/fck_image.js line 500 'if' statement if the file just ends with the extensions but not the dot, such as "fakepng".

  • Basically, the dot at the beginning is ".(extensions)", but should be "
    .(extensions) because the dot alone is anything and not just a dot.

This may not be urgent as the browser (or something) kicks it back anyway if the file isn't the correct type underneath, but it shouldn't get that far if it's obviously incorrect and it's an easy fix.

Change History (3)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added; upload extension check js removed

comment:2 Changed 10 years ago by Artur Formella

Version: FCKeditor 2.6.3FCKeditor 2.4

comment:3 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy