Opened 9 years ago

Closed 6 years ago

#2656 closed Bug (invalid)

Table: insert row/column produces unexpected results in the presence of merged cells

Reported by: thiloplanz Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: FCKeditor 2.6.3
Keywords: Cc:

Description

In the presence of merged table cells (colspan or rowspan), inserting rows or columns produces table rows with missing cells.

(see the attached picture, where the cell in the lower right corner is missing)

The user would expect the merged cells to be extended (increasing the colspan or rowspan), for example like Excel or TinyMCE do it, or at least end up with an appropriate number of unmerged cells.

Attachments (2)

DocumentLocalFile.jpg (17.7 KB) - added by thiloplanz 9 years ago.
screenshot
2656.patch (8.2 KB) - added by Koen Willems 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by thiloplanz

Attachment: DocumentLocalFile.jpg added

screenshot

comment:1 Changed 9 years ago by thiloplanz

see the attached picture, where the cell in the lower right corner is missing, after first merging the two cells on the right and then inserting a new row.

screenshot

comment:2 Changed 9 years ago by thiloplanz

deleting rows or columns has similar problems

comment:3 Changed 9 years ago by Martin Kou

Keywords: Confirmed added; table colspan rowspan removed

Confirmed the problem in both IE and FF.

comment:4 Changed 9 years ago by thiloplanz

splitting merged cells has similar problems

Changed 9 years ago by Koen Willems

Attachment: 2656.patch added

comment:5 Changed 9 years ago by Koen Willems

In tablehandler.js currently a clone is made of the row or column to copy it. Problems occur when those rows have cells spanning rows or columns.

I made a patch to insert just flat rows or columns (without colspans or rowspans). Furthermore I disabled the possibility to insert new rows or columns in certain occasions. For example: in the above picture I disabled the ability to insert a new row before/above cell a, since that cell is rowspanned by the cell in the preceding column.

So one has to insert new rows or columns at logical places in the table.

comment:6 Changed 7 years ago by Wiktor Walc

Component: GeneralCore : Tables

comment:7 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

This issue is no longer valid

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy