Opened 11 years ago

Closed 8 years ago

#2659 closed Bug (worksforme)

Word pasted content jumps to the bottom of the editor

Reported by: Adrian Roselli Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: IE7 Cc:

Description

Issue: MS Word pasted content jumps to the bottom of the editor when switching views (such as to Source view and back).

I have tested this in 2.6 and on the demo of 2.6.3 and it happens in both using IE7/Win. I cannot reproduce it start-to-finish in Firefox. These are the steps to reproduce it:

  1. Starting with a page of pre-existing, well-formatted content, delete a paragraph in the middle.
  1. Paste a simple block of copy from MS Word, being careful to NOT use the 'Paste from Word' feature.
  1. Put the cursor after the last character of the copy you've just pasted, hit the Enter key.
  1. Use the 'Paste from Word' feature to paste in the same content, checking both boxes in the dialog.
  1. Flip to Source view and back. The content you pasted last will have jumped to very bottom of the page.

This keeps happening with some of our users. It may be a function of pre-existing bad code on the page, or they paste the wrong way and try to fix it. Either way, it happens regularly. I have been through the forums and support tickets but did not find anything that matched. Has anyone else seen this or heard of a workaround?

Posted in the support forum as http://www.fckeditor.net/forums/viewtopic.php?f=6&t=12106

Change History (3)

comment:1 Changed 11 years ago by Adrian Roselli

Keywords: MS Word paste formatting added
Version: FCKeditor 2.6

comment:2 Changed 11 years ago by Artur Formella

Keywords: Confirmed IE7 added; MS Word paste formatting removed

Confirmed in IE7.

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy