Opened 10 years ago

Closed 7 years ago

#2688 closed Bug (wontfix)

fck_paste.html: paste from word fails with ++ in url

Reported by: Christian Zagrodnick Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: FCKeditor 2.4
Keywords: Cc:

Description

The offending line is 138:

var re = new RegExp( window.location + "#", "g" ) ;

It takes the window location as regexp which is not a good idea.

With an url like http://localhost:8080/++skin++cms/@@/gocept.fckeditor/editor/dialog/fck_paste.html that doesn't work:

invalid quantifier +skin++cms\/@@\/gocept.fckeditor\/editor\/dialog\/fck_paste.html#

A simple string replace would do!

Change History (5)

comment:1 Changed 10 years ago by Artur Formella

Component: GeneralUI : Dialogs
Keywords: Confirmed added
Version: FCKeditor 2.6.3FCKeditor 2.4

comment:2 Changed 10 years ago by Christian Zagrodnick

Version: FCKeditor 2.4FCKeditor 2.6.4

Still there in 2.6.4

comment:3 Changed 10 years ago by Artur Formella

Version: FCKeditor 2.6.4FCKeditor 2.4

FCKeditor 2.4 is the oldest version in which this bug occur.

comment:4 in reply to:  description Changed 10 years ago by Artur Formella

I was also not able to reproduce this bug in CKEditor 3.0 RC.

comment:5 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy