Opened 9 years ago

Closed 5 years ago

#2701 closed Bug (wontfix)

I have been having a bit of a problem in using numbered lists in FCKEditor.

Reported by: Anderson Gomes Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: FCKeditor 2.4
Keywords: Cc: anderson.gomes@…, andersongomesu@…

Description

I can create multiple lines of text, then select this text and click on numbered list icon on tool bar and convert the text to numbered list. So far so good, every thing appears to work fine.

Now if I select the items of the numbered list and change the font, only the font of the text that I had entered changes, but the font of the numbering (1, 2, 3, 4 etc appearing before each list item) stays as earlier. When I looked at the HTML source, I found that the font is getting applied to the content portion only (individually, inside the <LI> tag). For example, the source looks like:

<ol type="1" start="1"> <li><font size="4">This is item number 1</font></li> <li><font size="4">This is item number 2</font></li> <li><font size="4">This is item number 3</font></li> </ol>

How can I get the font selection to be applied as:

<font size="4"> <ol type="1" start="1"> <li>This is item number 1</li> <li>This is item number 2</li> <li>This is item number 3</li> </ol> </font>

Thanks,

Anderson Gomes

Change History (3)

comment:1 Changed 9 years ago by Martin Kou

Keywords: numbered list removed
Milestone: FCKeditor 2.6.4
Priority: HighNormal

Removing from 2.6.4 since major changes to the current style system is required to fix this.

comment:2 Changed 9 years ago by Artur Formella

Keywords: Confirmed added
Version: FCKeditor 2.4

The same bug occur in Google Docs.

comment:3 Changed 5 years ago by Jakub Ś

Cc: anderson.gomes@telecomrio.com.br; andersongomesu@gmail.comanderson.gomes@telecomrio.com.br, andersongomesu@gmail.com
Resolution: wontfix
Status: confirmedclosed

FCKeditor is no longer supported and we have few such tickets reported for CKEditor.

This will be fixed in CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy