Opened 15 years ago

Closed 15 years ago

#2703 closed New Feature (wontfix)

FCKeditor objects rename proposal

Reported by: Paul Moers Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Confirmed Cc:


When scripting around the editor I create a bunch of references to the objects of the FCKeditor, some of which the name differs from its name in the FCKeditor. If find my names more clear and less ambiguous.

editorFrame = document.getElementById(editorInstance.Name + '___Frame');
editorWindow = editorInstance.EditorWindow.parent;
editorDocument = editorWindow.document;
editorBody = editorDocument.body;
editingAreaWindow = editorInstance.EditorWindow;
editingAreaDocument = editorInstance.EditorDocument;
editingAreaBody = editingAreaDocument.body;
editingAreaIFrame = getElement('xEditingArea').getElementsByTagName('iframe')[0];

I hope this also makes sense to you guys and gets adopted.

Change History (2)

comment:1 Changed 15 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 15 years ago by Alfonso Martínez de Lizarrondo

Resolution: wontfix
Status: newclosed

No such changes are gonna happen currently in 2.x, you could propose it for 3.x, but it's not clear to me why is there a need to provide an alias for .body or in general provide alias that aren't used in the code of the editor itself. They might not be used by anyone and they add some extra burden in terms of code size.

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy