Opened 11 years ago

Closed 7 years ago

#2708 closed Bug (wontfix)

FCK_link.js Email Protection

Reported by: Stefan Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: Cc:

Description

When using email protection when creating an email link. You get an javascript error if you have a body text with 2 lines in it.

Error: untermintated string literal

Tested on FCKeditor Nightly Build with FireFox 3.0.4

Attachments (1)

screenshot.png (17.5 KB) - added by Stefan 11 years ago.
Screenshot of the input

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Stefan

Attachment: screenshot.png added

Screenshot of the input

comment:1 Changed 11 years ago by Artur Formella

I was unable to reproduce this bug. Could you provide more information? Do you have FCKConfig.EMailProtection set to 'function'?

comment:2 Changed 11 years ago by Stefan

Upload a movie file where you can see whats the problem. Used email protection FCKConfig.EMailProtection = 'encode' ;

https://rcpt.yousendit.com/636945548/8eb9254cbb5e2d4a3a3e6e012eebf0ee

comment:3 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Version: SVNFCKeditor 2.4

Confirmed in FF and IE. Link in preview mode:

<a href="
javascript:void(location.href='mailto:'+String.fromCharCode(116,101,115,116,64,116,101,115,116,46,99,111,109)+'?body=line1%0Aline2')
">are</a>

FCKConfig.EMailProtection setting is not important.

comment:4 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor is retired and this problem does not occur in CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy