Opened 10 years ago

Closed 8 years ago

#2727 closed Bug (worksforme)

FCKDomTools.GetIndexOf(node) failed for IE

Reported by: Dongqiang Bai Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: FCKeditor 2.5 Beta
Keywords: HasPatch IE Cc:

Description

Steps to reproduce

  1. Load following code into source view:
<P><SPAN><P>aaa</P></SPAN><P>bbb</P>
  1. Back to WYSIWYG
  1. Press enter key
  1. Move cursor to the end of "aaa", press enter key

Expected results

Step 3 should create a new line at the page top.

Step 4 should create a new line between "aaa" and "bbb".

Current behavior

Step 3 created a new line between "aaa" and "bbb".

Step 4 created a new line at the page top.

Browsers

IE6, IE7.

Known facts

For IE6/IE7, the following is surprisingly true for above example:

node.firstChild ≠ node.childNodes[0]

Attached test.html can show above effects.

Attachments (3)

test.html (782 bytes) - added by Dongqiang Bai 10 years ago.
test.html
patch.GetIndexOf (1.1 KB) - added by Dongqiang Bai 10 years ago.
patch tried to fix #2727
GetIndexOf.patch (1.1 KB) - added by Dongqiang Bai 10 years ago.
rename patch

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Dongqiang Bai

Attachment: test.html added

test.html

Changed 10 years ago by Dongqiang Bai

Attachment: patch.GetIndexOf added

patch tried to fix #2727

Changed 10 years ago by Dongqiang Bai

Attachment: GetIndexOf.patch added

rename patch

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed HasPatch added
Version: FCKeditor 2.5 Beta

comment:2 Changed 10 years ago by Artur Formella

Keywords: IE added

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy