Opened 11 years ago

Closed 11 years ago

#2732 closed Bug (fixed)

Formatted (<pre>) content is replaced by "_FCKpd_1" when entering source mode

Reported by: Ian Danforth Owned by: Alfonso Martínez de Lizarrondo
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.4
Component: Core : Styles Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

  1. Go to nightly build

http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

  1. Select sample text and change to "Formatted" format
  2. Click the Source button

Expected:

Same text in <pre> </pre> tags.

Observed:

<pre>_FCKpd_1</pre>

Note: Marked high as this will garble any existing code snippets using this format.

Attachments (1)

2732.patch (1.1 KB) - added by Alfonso Martínez de Lizarrondo 11 years ago.
Proposed patch

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by Brian Klug

I can reproduce this 100% of the time.

comment:2 Changed 11 years ago by Mark

From r2570 - r2618 (inclusive), the Source button was broken. r2619 fixed the Source button but introduced this bug.

The patch seems to be related to the Array::AddItem() instances that r2619 tried to clean up.

comment:3 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed Review? added
Milestone: FCKeditor 2.6.4
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned
Version: SVN

The problem is that the calls changed in [2619] used the .AddItem as a function, using the returned value, but it turns out that Array::push() returns the length of the new array, and the custom .AddItem did return the index of the new element.

The following patch should fix it.

Changed 11 years ago by Alfonso Martínez de Lizarrondo

Attachment: 2732.patch added

Proposed patch

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [2782]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy