Opened 10 years ago

Closed 6 years ago

#2735 closed Bug (wontfix)

clicking link in Opera when text is selected doesn't clear selection [CORE-35943]

Reported by: fahrao Owned by:
Priority: Low Milestone:
Component: General Version: 3.4.1
Keywords: Opera Cc:

Description (last modified by Krzysztof Studnik)

Steps to recreate bug

  1. Open demo
  2. Select any of the text outside of link
  3. Now click on link to try to put cursor inside of link (or double-click link to try to select it).

Faulty behaviour: Previous selected text stays selected and cursor can not be placed in link. Expected behaviour: Cursor should be placed inside the link

Can be reproduced every time.

Tested with Opera 9.63 and 9.62, FCKEditor 2.6.3 and nightly build.

Change History (7)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added; link selection removed

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Opera added

Still confirmed with Opera 10 build 1703.

comment:3 Changed 9 years ago by Krzysztof Studnik

Description: modified (diff)
Version: FCKeditor 2.6.33.4.1 (SVN - trunk)

Confirmed on Opera 10.61.3484, CKE 3.4.1 Trunk & Demo

  • selection on link works normal (highlight of selected text is disabled, and selection goes to link)
  • Click on link, does not disable text highlight

comment:4 Changed 9 years ago by Garry Yao

Only occurs on range selection on text then cursor selection on link.

comment:5 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Priority: NormalLow
Summary: Impossible to move cursor to link in Opera when text is selectedImpossible to move cursor to link in Opera when text is selected [CORE-35943]

confirmed Opera bug, reported as CORE-35943

comment:6 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Summary: Impossible to move cursor to link in Opera when text is selected [CORE-35943]clicking link in Opera when text is selected doesn't clear selection [CORE-35943]

(trying to clarify summary a bit - not sure if it is an improvement, feel free to change it back..)

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

Presto is not supported any more, since Opera switched to Blink.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy