Opened 10 years ago

Closed 6 years ago

#2742 closed Bug (fixed)

FF3: Detached toolbar disappears when display is toggled between none and block

Reported by: ahjort Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: Cc:

Description

I have an editor with ToolbarLocation = Out:toolbarDIV. Both editor and toolbarDIV is wrapped in another DIV. When the outer DIV is toggled between "display:none" and "display:block" a few times, the toolbar disappears. It varies how many times you have to do the toggle.

Also if the outer DIV is set to "display:none" in the stylesheet and you toggle after the editor has loaded, the toolbar never shows.

This is in Firefox 3.0.5 on WinXP. IE7, Chrome and Opera works fine.

Attachments (2)

index.htm (1.2 KB) - added by ahjort 10 years ago.
2742.jpg (13.7 KB) - added by Artur Formella 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by ahjort

Attachment: index.htm added

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed FF3 added
Version: FCKeditor 2.5

It is a very strange bug.

Steps to reproduce:

1-open attached index.htm (FF3)

2-click Hide editor

3-minimize FF or click (to focus on) other application

4-back to FF

5-click Show editor

6-repeat one more time (steps 2-5)

Changed 10 years ago by Artur Formella

Attachment: 2742.jpg added

comment:2 Changed 6 years ago by Jakub Ś

Keywords: FireFox3 removed
Resolution: fixed
Status: confirmedclosed

I have treied this TC in latest CKEditor 4.1 and was not able to reproduce. I'm closing this ticket as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy