Opened 11 years ago

Closed 11 years ago

#2747 closed Bug (duplicate)

alignment in div with break creates new div

Reported by: Dave Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.5 Beta
Keywords: Confirmed Cc:

Description

When I enter the following html in the nightly build:

<div style="position: absolute; top: 10mm; left: 20mm;" id="testid">this is some text <br />
and some more</div>

and I select (some part of) the first line and align it to the right, I get:

<div id="testid" style="position: absolute; top: 10mm; left: 20mm; text-align: right;">this is some text</div>
<div id="testid" style="position: absolute; top: 10mm; left: 20mm;">and some more</div>

which is unexpected for me. The positioning makes it look as if the text has disappeared.

If no break is present, it will put the alignment in the div (and not create a new one). This is what I expected.

Change History (6)

comment:1 Changed 11 years ago by Dave

Using windows XP and Firefox 3.0.3

comment:2 Changed 11 years ago by Artur Formella

Keywords: Pending WorksForMe added

I was unable to reproduce this bug in FF 3. Could you provide more information? Does it occur always?

comment:3 Changed 11 years ago by Dave

You are right, there is some more to it...

Go to Sample 12 and change 'when Enter is pressed' to 'Break the line with a <BR>' and then try it.

comment:4 Changed 11 years ago by Dave

There seems to be an overlap with bug 2079.

comment:5 Changed 11 years ago by Artur Formella

Keywords: Confirmed added; Pending WorksForMe removed
Version: FCKeditor 2.5 Beta

Yes. Now I can conform this bug.

comment:6 Changed 11 years ago by Artur Formella

Resolution: duplicate
Status: newclosed

Ok, I connect both tickets.

DUP of #2079

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy