Opened 11 years ago

Closed 11 years ago

#2764 closed Bug (fixed)

Source area is having the wrong size in IE

Reported by: Martin Kou Owned by: Garry Yao
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: UI : Source View Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Review+ Cc:

Description

To reproduce:

  1. Open the replacebyclass.html sample in IE6.
  2. Add a default 2x3 table there.
  3. Switch to source mode.
  4. The HTML source for the table is seemingly not there... but it's only because the source mode text area is too small and is having s scroll bar.

Attachments (5)

plugin.js.diff (1.3 KB) - added by Garry Yao 11 years ago.
2764.diff (1.3 KB) - added by Garry Yao 11 years ago.
Name convention revised
2764.patch (1.3 KB) - added by Garry Yao 11 years ago.
Name convention revised
2764.2.patch (6.8 KB) - added by Garry Yao 11 years ago.
Code style revised
2764_3.patch (1.0 KB) - added by Garry Yao 11 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed IE added

comment:2 Changed 11 years ago by Martin Kou

Priority: NormalHigh

Putting to high priority so it will be fixed before the beta release.

comment:3 Changed 11 years ago by Martin Kou

Owner: set to Garry Yao

Changed 11 years ago by Garry Yao

Attachment: plugin.js.diff added

comment:4 Changed 11 years ago by Garry Yao

Keywords: Review? added

Changed 11 years ago by Garry Yao

Attachment: 2764.diff added

Name convention revised

Changed 11 years ago by Garry Yao

Attachment: 2764.patch added

Name convention revised

comment:5 Changed 11 years ago by Martin Kou

Keywords: Review- added; Review? removed

Review- because the patch path and the coding styles of this patch do not conform to our standards. I've talked to Garry about the coding standards we have.

The patch works otherwise.

Changed 11 years ago by Garry Yao

Attachment: 2764.2.patch added

Code style revised

comment:6 Changed 11 years ago by Martin Kou

Hmm...

  1. The automatic code formatter seems to have turned a lot of the tabs into spaces - that's bad.
  2. Same for the comments, it reformatted the comments to exceed the 80-character limit in the style guidelines.
  3. The 0xfeff character at line 7 makes the patch unusable with GNU patch or TortoiseSVN. I guess you'd better generate the patch with TortoiseSVN rather than with the Eclipse plugin.

Changed 11 years ago by Garry Yao

Attachment: 2764_3.patch added

comment:7 Changed 11 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:8 Changed 11 years ago by Garry Yao

Status: newassigned

comment:9 Changed 11 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:10 Changed 11 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [2952].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy