Opened 10 years ago

Closed 10 years ago

#277 closed Bug (fixed)

Bulleted lists do not work as expected if alignment for the paragraph was changed.

Reported by: mshmulenson Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: Core : Styles Version: FCKeditor 2.4.1
Keywords: Confirmed SD-COE Cc: pkdille, Jean-Marc Libs, Nyloth

Description

The bullet lists work as expected under normal circumstances. For example, you click on a line of text, select ordered or unordered bullets to make that line the first bullet. After that you can simply press enter at the end of the line and another empty bullet will appear and allow you to type in the appropriate text. This functionality does not work if the alignment was changed for the paragraph before turning on the bullets. If alignment has changed, then the bullet receives <div align="xxxx">xx</div> as its content. As a result, when enter is pressed, new paragraphs get created inside this div, and no new bullets appear.

Change History (17)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added

(Almost) confirmed with FF2 and IE6.

I was able to reproduce it only by aligning the text after the bullet has been applied.

While I don't think the behavior would change if we have a <div>, we should instead change it to apply the alignment to the <li> tag itself, producing <li style="text-align:right">, for example.

comment:2 Changed 10 years ago by Jon Brooks

We ran into this issue as well. It seems only to occur with IE6 and IE7. Below are some specific steps for reproducing the bug by applying alignment before the bullet had been applied:

  1. Create a new page
  2. Select 'Center' justification
  3. Enter a few lines of text
  4. Highlight all of the lines, then select 'Left' justification
  5. Go to the last line of text, hit return (or multiple lines)
  6. Click on the bulleted list icon for a bulleted list
  7. enter a line of text, hit return

Results: A new bullet is not created.

Hope this info helps.

comment:3 Changed 10 years ago by Jon Brooks

Even simpler steps are below(this happens with FF and IE):

  1. Create a Bulleted list
  2. Select 'Heading 2'
  3. Type some text, hit return

Result:
No new Bullets appear

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles
Milestone: FCKeditor 2.5

Let's see if the new Style System will help us solving this issue.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: SD-COE added

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Cc: Pascal.KUSTNER@… added

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Cc: jean-marc.libs@… patrice.weber@… added

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Cc: pkdille Jean-Marc Libs Nyloth added; Pascal.KUSTNER@… jean-marc.libs@… patrice.weber@… removed

comment:9 Changed 10 years ago by Jon Håvard Gundersen

The problem is that IE tries to remember the settings for the selected paragraph, even if these settings are specified with css. The quick solution is to clear all settings of the element which is converted to a list element before the conversion (which is done by IE named commands)

comment:10 Changed 10 years ago by Jon Håvard Gundersen

This bug also occurs if the text the user is trying to indent is formatted with em or strong tags, then IE wraps a div around the text and this breaks the list logic, possible related to #975

comment:11 Changed 10 years ago by Jon Håvard Gundersen

Seems to be a more general problem, if the text is surrounded with tags IE wrap a DIV around the element. (I.e. also anchors are places inside a div in the list)

comment:12 Changed 10 years ago by Jon Håvard Gundersen

and only if the selection is collapsed

comment:13 Changed 10 years ago by Jon Håvard Gundersen

sorry about all these comments... but the bug happens when the selection is collapsed or inside the an element :)

comment:14 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:15 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [804].

Click here for more info about our SVN system.

comment:16 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: closedreopened

The justify commands don't work when multiple blocks are selected after [804], reopening ticket.

comment:17 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: reopenedclosed

Fixed with [807].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy