Opened 10 years ago

Closed 7 years ago

#2800 closed Bug (invalid)

Wrong colspan after deleting column

Reported by: Koen Willems Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: FCKeditor 2.4
Keywords: Cc:

Description

Take a 3 * 2 table like this:

    <table title="tabel" cellspacing="0" cellpadding="0" summary="table">
        <thead>
            <tr>
                <th scope="col">1</th>
                <th scope="col">2</th>
            </tr>
        </thead>
        <tbody>
            <tr>
                <td>a</td>
                <td>b</td>
            </tr>
            <tr>
                <td colspan="2">c</td>
            </tr>
        </tbody>
    </table>

Now right click in cell b and delete that column. You will see that the colspan of cell c is not lowered (or, in this case, removed).

Attachments (2)

2800.patch (2.2 KB) - added by Koen Willems 10 years ago.
2800_2.patch (2.3 KB) - added by Koen Willems 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Koen Willems

Attachment: 2800.patch added

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added
Version: FCKeditor 2.4

comment:2 Changed 10 years ago by Koen Willems

I stumbled upon problems with deleting a column in a table like this:

<table title="table" cellspacing="0" cellpadding="0" summary="table">
    <thead>
        <tr>
            <th scope="col">1</th>
            <th scope="col">2</th>
            <th>3</th>
        </tr>
    </thead>
    <tbody>
        <tr>
            <td>a</td>
            <td rowspan="3">b</td>
            <td rowspan="2">c</td>
        </tr>
        <tr>
            <td>c</td>
        </tr>
        <tr>
            <td>d</td>
            <td>e</td>
        </tr>
        <tr>
            <td>f</td>
            <td colspan="2">g</td>
        </tr>
    </tbody>
</table>

So, I did some dirty trick in the previous patch. By the way, the new patch is only working in conjunction with this patch: http://dev.fckeditor.net/attachment/ticket/2859/2859.patch

Changed 10 years ago by Koen Willems

Attachment: 2800_2.patch added

comment:3 Changed 8 years ago by Wiktor Walc

Component: GeneralCore : Tables

comment:4 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy