Opened 11 years ago

Closed 7 years ago

#2806 closed Bug (wontfix)

MoveToAncestorNode failing in IE if you look for the selected item

Reported by: Robert Neve Owned by:
Priority: Low Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: Cc:

Description

I have a plug-in that adds an image with a specially configured alt tag. When I select this tag and open by plug-in window firefox was able to read in the data. IE was not. I soon found this was because it was automatically looking at the parent node of the image. I corrected it in my code by changing the MoveToAncestorNode code to contain this

if(oRange(i).nodeName == A)

return oRange(i);

In the first for loop before it checks for a parent node. Is there any way the new version will have something in it already so IE checks to see if you have the item you're looking for as I have done? Attached is the javascript file I edited.

Attachments (3)

fckeditorcode_ie.js (576 bytes) - added by Robert Neve 11 years ago.
BlockInsert.php (2.5 KB) - added by Robert Neve 11 years ago.
PageInsert.php (3.2 KB) - added by Robert Neve 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by Robert Neve

Attachment: fckeditorcode_ie.js added

comment:1 Changed 11 years ago by Artur Formella

Keywords: Pending added

How to reproduce this bug? Could you attach your plugin or provide more information?

comment:2 Changed 11 years ago by Robert Neve

It's tricky since the editor is used through drupal and some other code is required but I have attached one of the plug-in files anyway although. It should run ok I think except for the directory tree.

Changed 11 years ago by Robert Neve

Attachment: BlockInsert.php added

Changed 11 years ago by Robert Neve

Attachment: PageInsert.php added

comment:3 Changed 11 years ago by Artur Formella

Milestone: FCKeditor 2.6.4

comment:4 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: pendingclosed

FCKeditor is no longer supported.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy