Opened 9 years ago

Closed 9 years ago

#2822 closed Bug (fixed)

V3: Configurations must not use sub-namespaces

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Cc:

Description

This is something we though would be good, but I've just found out that it's evil. We must not use namespaces to organize the configurations under CKEDITOR.config, like CKEDITOR.config.dialog.magnetDistance.

The reason why is that, if you try to change this setting in a custom configuration file (like the root config.js), the namespace (CKEDITOR.config.dialog) will not yet be available, because the dialog plugin will not yet be loaded. So, the execution breaks.

We should still organize the configurations in a meaningful way, so I'm opting to use a "prefix", instead of a namespace there. In the above case, we would have CKEDITOR.config.dialog_magnetDistance.

Change History (3)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

I'm taking care of the stuff already moved to trunk. There will still be pending things at the prototype though.

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

The trunk is done with [3007]. The prototype is still pending.

Side note: it's not a big issue to repeat CKEDITOR.config in the code. This is one of those namespaces that get automatically reduced to a single char by our packager (look for the PACKAGER_RENAME directive at config.js).

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Ok, closing this one as we need the trunk to be in good health now. Other things will be fixed when moving the prototype pending things.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy