Opened 10 years ago

Closed 7 years ago

#2873 closed New Feature (wontfix)

Server side integration - File Browser

Reported by: Wiktor Walc Owned by: Wiktor Walc
Priority: Normal Milestone:
Component: File Browser Version:
Keywords: Discussion Cc:

Description

Port the file browser from V2.

Attachments (3)

2873.patch (225.8 KB) - added by Wiktor Walc 10 years ago.
2873_images.zip (10.5 KB) - added by Wiktor Walc 10 years ago.
2873_test_plugin.zip (2.1 KB) - added by Wiktor Walc 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Wiktor Walc

Owner: set to Wiktor Walc

Changed 10 years ago by Wiktor Walc

Attachment: 2873.patch added

Changed 10 years ago by Wiktor Walc

Attachment: 2873_images.zip added

Changed 10 years ago by Wiktor Walc

Attachment: 2873_test_plugin.zip added

comment:2 Changed 10 years ago by Wiktor Walc

In the 2873_test_plugin.zip file there is a dummy plugin just to help in testing the filebrowser plugin, it will a blank button to the toolbar (...).

Files from 2873_images.zip should be copied into _source\plugins\filebrowser directory.

Some probably ugly things:

  • I had to style some elements in the dialog box, I have done it with the style tag which is rather a bad idea.
  • Two global functions are registered: SetUrl and OnUploadCompleted to connect with the external file browser / file uploader.
  • Some variables are stored in [editor_instance].plugins.filebrowser, I'm not sure whether it's the best place to put those variables/functions.

For a better understanding of this plugin the filebrowsertest plugin may come in handy.

It is possible to use the external file browser either by setting these variables:

CKEDITOR.config.filebrowser_browse_url
CKEDITOR.config.filebrowser_upload_url

or by setting the filebrowser.url attribute for a specific UI element:

  filebrowser : 
  {
  	action : 'Browse',
  	url : '/ckfinder/ckfinder.html?action=js&func=SetUrl&thumbFunc=SetUrl&type=Images',
  	updateOnSelect : ['tab1', 'id10']
  }
  filebrowser : 
  { 
  	action : 'QuickUpload', 
  	url : '/ckfinder/core/connector/php/connector.php?command=QuickUpload&type=Files',
  	updateOnUpload : ['tab1', 'id10'] 
  },  

Because there is a possibility that someone might want to use two or more different file browsers at the same time in CKEditor, the filebrowser plugin will attach itself automatically only to the elements with the following IDs: 'browse', 'uploadButton', 'url'.

comment:3 Changed 10 years ago by Wiktor Walc

Keywords: Review? added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.x

comment:5 Changed 10 years ago by Artur Formella

#3895 has been marked as DUP

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Discussion added; Confirmed Review? removed
Milestone: CKEditor 3.x

At this time, we're not likely to have the file browser in CKEditor.

comment:7 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy