Opened 10 years ago

Closed 5 years ago

#288 closed New Feature (duplicate)

Modify linker to allow internal CMS links.

Reported by: George M. Harkin Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: HasPatch Cc: amos

Description

Internal Links Modification

I have been modifying the CMSContent plugin posted on the forums to work with the Drupal CMS.

While in development, I realized that this plugin would be a great addition to the core of FCK. Perhaps adding an option to specify something that should be prepended to CMS links so they are consistent after host or folder changes.

For example, in the default linker, there could be another tab for "Internal Link" which would display a list or tree of the pages in the site. The only difference between selecting one of these internal links and a regular link is that it would prepend, in Drupal's case, "internal:" to the url.

Areas to consider

  • A list a pages of the CMS is required. Perhaps calls a PHP, ASP, or whatever script that returns some JSON of Titles and URLs.
  • All internal links would need to have the proper structure appended, but this could be taken care of by the script call.
  • Anything in the preview would need to have the 'internal:' or whatever replaced to display correctly. The replacement string could be set in the FCK config at load time.

Requirements supplied to FCK

  • Script location to return list of Titles and URLs
  • Replacement for special string to allow previews to work ie 'internal:' => '/webdev/testing_drupal_site/'

I am just thinking aloud, so please feel free to chime in.

Attachments (1)

288.patch (89.1 KB) - added by Artur Formella 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by Artur Formella

Keywords: link cms internal removed

#2393 has been marked as dup

comment:2 Changed 9 years ago by Artur Formella

Keywords: Confirmed added

comment:3 Changed 9 years ago by Artur Formella

Owner: set to Artur Formella
Status: newassigned

Changed 9 years ago by Artur Formella

Attachment: 288.patch added

comment:4 Changed 9 years ago by Artur Formella

Keywords: HasPatch added

I attached a patch. It is not a final solution.

Here is info how to set connector url:

http://www.mysite.com/internal.xml
InternalLinksUrl 		= "http://www.mysite.com/internal.xml";
InternalLinksSearch = false;

http://www.mysite.com/index.php?search=QUERY
InternalLinksUrl 		= "http://www.mysite.com/index.php";
InternalLinksSearch = "search=";

http://www.mysite.com/?a=b&c=d&q=QUERY
InternalLinksUrl 		= "http://www.mysite.com/?a=b&c=d";
InternalLinksSearch = "q=";

http://www.mysite.com/?QUERY
InternalLinksUrl 		= "http://www.mysite.com/";
InternalLinksSearch = "?";

http://www.mysite.com/?a=b&QUERY
InternalLinksUrl 		= "http://www.mysite.com/?a=b";
InternalLinksSearch = "?";

http://www.mydrupal.com/QUERY
InternalLinksUrl 		= "http://www.mydrupal.com/";
InternalLinksSearch = "";

has anyone any advice?

comment:5 Changed 8 years ago by Artur Formella

Owner: Artur Formella deleted
Status: assignednew

comment:6 Changed 7 years ago by Wiktor Walc

Looks like an awesome idea for a plugin for CKEditor. Would you be willing to create a similar plugin for CKEditor? We could distribute it later as a separate plugin.

comment:7 Changed 7 years ago by Wiktor Walc

Version: FCKeditor 2.5

comment:8 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Cc: amos added

#6475 has been marked a dup.

An implementation for CKEditor is available at http://blog.xoundboy.com/?p=393

comment:9 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

FCKeditor is no longer supported. The same ticket has been reported for CKEditor 4 (#9806) thus I'm closing this one as duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy