Opened 10 years ago

Closed 10 years ago

#2881 closed Bug (fixed)

Need to click on Submit button twice if there are multiple fckeditor controls in one asp.net page

Reported by: jefftu Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: Cc: kerry@…

Description

Steps to reproduce:

  1. Create six fckeditor controls in one asp.net page (please see the attached aspx file).
  2. Click inside the second fckeditor control, type anything inside it.
  3. Scroll down to show the submit button, click on it. The click event handler of the submit button is not called, instead the focus jumps back to the second fckeditor control.
  4. Click on the submit button again, this time the page is submitted successfully.

Expected behavior: Click on the submit button should not jump back to the fckeditor control. User should never need to click on the submit button twice to submit the page.

Note: This issue did not exist in earlier version (2.2.x). I ran into this issue after I upgraded to 2.6.3, and it still exists after I upgraded to 2.6.4.

Attachments (2)

fckconfig.js (13.5 KB) - added by jefftu 10 years ago.
Upload.aspx (9.8 KB) - added by jefftu 10 years ago.

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by jefftu

Attachment: fckconfig.js added

Changed 10 years ago by jefftu

Attachment: Upload.aspx added

comment:1 Changed 10 years ago by Steve

I am having the same problem. When editing a webpage within Drupal, when I click on the "submit" button at the bottom of the page I am sent back to the text editing window. After clicking on the "submit" button a second time, everything works as expected.

I am running FCKeditor 2.6.3 with Drupal v5.15 and version 5.x-2.2-rc6 of the associated Drupal module that enables Drupal to work with the FCK editor.

The problem is happening when I use Internet Explorer, version 7.0. Haven't tried other versions of IE. With Firefox 3.0.6, on the same computer, the problem does not occur.

comment:2 Changed 10 years ago by Paul Warren

I am also having the problem, IE 6. Also after being send back to the text area on submit click, the editor acts strange, events seem to be missing, if the backspace button is pressed the browser initiates it's back event. If anyone knows a work around for this, posting it here would be greatly appreciated.

comment:3 Changed 10 years ago by Artur Formella

Keywords: multiple controls focus lock click twice removed

comment:4 Changed 10 years ago by dougd_nc

Priority: NormalHigh

I ran into this too. It's a pretty serious problem especially if people think they have saved their work by clicking submit and they have not. Hopefully some one is working on this one.

comment:5 Changed 10 years ago by dougd_nc

also,I wanted to add that this sounds like a similar issue to this: http://docs.fckeditor.net/FCKeditor_2.x/Developers_Guide/Troubleshooting#AspRequiredField (With ASP.NET, I need to submit twice when using the RequiredFieldValidator in a FCKeditor instance)

Maybe FCK thinks that the field failed a validation check and goes back to allow the user to change it.

However, I am not using ASP.NET, I am not using Validators, the error occurs even if the user has typed something in the field, and it only happens in IE.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Priority: HighNormal

comment:7 Changed 10 years ago by Kerry

Cc: kerry@… added
Version: FCKeditor 2.6.4FCKeditor 2.6.3

I am too having the same issue with both IE6 and IE7. This also happens when there is only 1 fckeditor and no validators has been added in the webpage.

the version of the fckeditor that i am using is version 2.6.3 Build 19836 which comes in with dotnetnuke version 04.09.02

comment:8 Changed 10 years ago by Paul Warren

Upon upgrading to CKEditor this issue no longer exists for me, thank you for the new editor it is very nice!

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

I'm happy to hear that this is not anymore an issue with CKEditor 3.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy