Opened 11 years ago

Closed 11 years ago

#2954 closed Bug (fixed)

Option 'Match cyclic' not working

Reported by: Garry Yao Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IBM Review+ Cc: Damian

Description

The config option of Match cyclic which should restart the search from the beginning of document which doesn't work.
Reproducing procedure:

  1. Open Replace by code sample;
  2. Make selection as below:
    <p>This i^s some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
    
  3. Open the find/replace dialog, make sure only the match cyclic option is checked, fill in is in 'Find what' input, then click find button.
  4. Prompted with '...text not found', click find button again.
  • Expected result: The document is highlighted as
    <p>Th^is^ is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
    
    
  • Actual result: Again prompted '...text not found'.

Attachments (1)

2954.patch (469 bytes) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Martin Kou

Keywords: Confirmed added
Owner: set to Martin Kou
Status: newassigned

The bug isn't reproducible outright, but after repeating the procedure a few times does trigger it.

comment:2 Changed 11 years ago by Garry Yao

Keywords: IBM added

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Cc: Damian added

#2985 has been marked as DUP

Changed 11 years ago by Martin Kou

Attachment: 2954.patch added

comment:4 Changed 11 years ago by Martin Kou

Keywords: Review? added

The bug is caused by line 485 of the Find dialog file. It resets the search position to the position of the selection before the dialog is opened after the find reached the end of document. That's wrong. It should reset the search position back to the start of the document instead.

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:6 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3167].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy