Opened 10 years ago

Closed 7 years ago

#3023 closed Bug (invalid)

extra <br /> added on GetHTML()

Reported by: Dinu Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: FCKeditor 2.6.4
Keywords: Cc:

Description

On GetHTML(), a <br/> is added in the displayed body. It is out of place and not included in the GetHTML return, causing an inconsistency between fetched and displayed document.

The GetHTML() request should NOT alter in any way the layout of the document.

Change History (7)

comment:1 Changed 10 years ago by Dinu

On further testing, this seems to happen when the last element of the body is a block element: img, p, div etc. I also found a case when body text was wrapped in <p></p> which is quite wrong, but I can't replicate, I'll try some more.

comment:2 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

This is something we're trying to fix in v3, please keep watching the progress of #2886.

comment:3 Changed 10 years ago by Dinu

Connected problem: IsDirty always true when EnterMode='div' and last element is a block element (i.e. table).

comment:4 in reply to:  3 Changed 10 years ago by Garry Yao

Replying to dinu:

Connected problem: IsDirty always true when EnterMode='div' and last element is a block element (i.e. table).

Yes, it's also related to <br> handling logic, which doesn't appear in v3 now.

comment:5 Changed 10 years ago by Dinu

So will this also be fixed in 2.x?

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.5

comment:7 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy