Opened 11 years ago

Closed 11 years ago

#3035 closed Bug (fixed)

Javascript error in IE when using fckdialog to insert an image

Reported by: Eric E. Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Confirmed Cc:

Description

I have tried this several times in IE 6, using various different image settings (thumbnail, frame, border, right, left, etc) to no avail.

After I select my image using the fckdialog, I get an error in the following function, on the line indicated by my comments:

/**
 * Ensures that the editing area contains an active selection. This is a
 * requirement for IE, as it looses the selection when the focus moves to other
 * frames.
 */
EnsureSelection : function()
{
	// Move the focus to the Cancel button so even if the dialog contains a
	// contentEditable element the selection is properly restored in the editor #2496

// EE - Error occurs on the following line
	$( 'btnCancel' ).focus() ;
// EE

        window.focus() ;


	FCK.Selection.Restore() ;
}

Note: I see that the line in question has been added in the latest release, and was not present in release 2.6.3.

Attachments (1)

Snap1.jpg (154.1 KB) - added by Eric E. 11 years ago.
Screen shot of the error

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by Eric E.

Oops, in the process of pasting in my comments, I've screwed up the order of the lines in that function.

But the line I've marked above is still the offending line.

Sorry for any confusion.

Changed 11 years ago by Eric E.

Attachment: Snap1.jpg added

Screen shot of the error

comment:2 Changed 11 years ago by Garry Yao

Keywords: WorksForMe added; fckdialog IE 6 error removed
Version: FCKeditor 2.6.4

I was unable to reproduce this bug.

comment:3 Changed 11 years ago by Eric E.

I have "fixed" my local installation of fckeditor in the meantime by commenting out the offending line.

So I guess I can wait for a proper fix... but this does need to get fixed.

comment:4 Changed 11 years ago by Eric E.

By the way, the error does NOT occur with every browser.

It does work fine for me in Firefox. So far I've only experienced the error with IE 6.

comment:5 Changed 11 years ago by Wiktor Walc

Component: UI : DialogsProject : MediaWiki+FCKeditor
Keywords: Confirmed added; WorksForMe removed
Resolution: fixed
Status: newclosed

It's a compatibility problem between MediaWiki plugin and FCKeditor 2.6.

Fixed with [3180].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy