Opened 10 years ago

Closed 10 years ago

#3057 closed New Feature (fixed)

V3 : Context Menu

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Context Menu Version:
Keywords: Confirmed Review+ Cc:

Description

Implement the context menu.

Attachments (1)

3057.patch (58.7 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 3057.patch added

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

Things that should not block the proposed patch:

  • It includes the context menu options for table stuff, but they don't work yet. I've included them only for testing, so we can check the multilevel support in the context menu system. Right now it supports only two levels.
  • Actually some of the context menu options may not work properly, specially in IE (due to the selection issue). This is to be solved by other tickets, not this one.
  • The text of the menu items may be cut if too long. There is no support for auto width yet.
  • No support for Opera yet. Right now it's supposed to work with IE and FF (Safari 4 is ok also).

All known issues will be handled by dedicated tickets during the stabilization.

comment:2 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

It's not working well for IE6 yet:

  1. The size of context menus is incorrect at the first menus are opened.
  2. The size of separators are incorrect.
  3. Scrollbars appear in context menus when the mouse cursor is inside the menus.

Since this ticket is urgent, I'll still Review+ it here. Please open separate ticket(s) for the issues mentioned above.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3170].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy