Opened 10 years ago

Closed 10 years ago

#3114 closed Bug (fixed)

V3: IE7 opening of the toolbar dropdown controls fires the onbeforeunload event

Reported by: mike890 Owned by: Garry Yao
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: 3.0 Beta
Keywords: Confirmed IE Review+ Cc: mike890

Description (last modified by Frederico Caldeira Knabben)

In V2 it worked fine but in V3 opening of the toolbar dropdown controls fires the windiw.onbeforeunload. To reproduce this bug simply add the following JS code and try to open a toolbar dropdown. Probably it happens because the new version uses IFrame for the dropdown content.

<script>
window.onbeforeunload = function() {
	alert("window.onbeforeunload");
		//if(CKEDITOR.instances["content"].checkDirty())
		//	return "Page has not been saved!";
	}
</script>

Attachments (1)

3114.patch (4.6 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by mike890

Cc: mike890 added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Confirmed IE added; onbeforeunload removed

I'm able to reproduce it with IE. Ok with FF. That's definitely weird, and critical.

Changed 10 years ago by Garry Yao

Attachment: 3114.patch added

comment:3 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

The 'onunload' event was found be to caused by IE default link behavior.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3303]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy