Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#3151 closed Bug (fixed)

Remove list command is not working

Reported by: Martin Kou Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Lists Version: SVN (FCKeditor) - Retired
Keywords: Review+ Cc:

Description

To reproduce:

  1. Open replacebyclass.html sample in any supported browser.
  2. Change the paragraph into a numbered list.
  3. Press numbered list button again.
  4. The list is not removed.

Attachments (3)

3151.patch (5.4 KB) - added by Martin Kou 10 years ago.
3151_2.patch (677 bytes) - added by Martin Kou 10 years ago.
3151_3.patch (5.0 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by Martin Kou

The bug is found to be caused by [3194].

There're at least two major changes which is breaking plugins:

  1. editor.config.enterMode is now changed to numeric constants. Any old code still depending on them being strings is broken.
  2. CKEDITOR.dom.node::clone() now removes element ID. Any old code that depends on the old id cloning behavior is broken.

comment:2 Changed 10 years ago by Martin Kou

Keywords: Review? added

Changed 10 years ago by Martin Kou

Attachment: 3151.patch added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

My fault here. I've wrongly assumed that that the enterKey setting is to be used by the enterkey plugin only, which is totally wrong. That's the reason why this setting is inside the core config instead of being along with the plugin.

comment:4 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [3249].

Click here for more info about our SVN system.

comment:5 Changed 10 years ago by Martin Kou

#3159 is a dup of this ticket.

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review+ removed
Resolution: fixed
Status: closedreopened

The problem still existed with enterMode=br.

Changed 10 years ago by Martin Kou

Attachment: 3151_2.patch added

comment:7 Changed 10 years ago by Martin Kou

Keywords: Review? added

Changed 10 years ago by Garry Yao

Attachment: 3151_3.patch added

comment:8 Changed 10 years ago by Garry Yao

R+ for 3151_2.patch,appending TC.

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:10 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: reopenedclosed

Fixed with [3313].

Click here for more info about our SVN system.

comment:11 Changed 7 years ago by Frederico Caldeira Knabben

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy