Opened 10 years ago

Closed 10 years ago

#3174 closed Bug (fixed)

CKEditor 3.0 - Context Menu is not displayed correctly

Reported by: Senthil Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Oracle Confirmed Review+ Cc: Senthil

Description

Screen shot attached

Attachments (8)

Context Menu.JPG (23.8 KB) - added by Senthil 10 years ago.
3174.patch (1.9 KB) - added by Garry Yao 10 years ago.
3174_2.patch (2.2 KB) - added by Garry Yao 10 years ago.
3174_3.patch (2.1 KB) - added by Garry Yao 10 years ago.
Picture 7.png (110.1 KB) - added by Martin Kou 10 years ago.
3174_4.patch (3.1 KB) - added by Martin Kou 10 years ago.
Picture 2.png (110.9 KB) - added by Martin Kou 10 years ago.
3174_5.patch (686 bytes) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (26)

Changed 10 years ago by Senthil

Attachment: Context Menu.JPG added

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Pending added

What's your browser version? I've tested it with IE7 and FF3, in both quirks and standards mode and it works well.

comment:2 Changed 10 years ago by Artur Formella

Keywords: Confirmed added; Pending removed

It is probably IE 6.0.

In FF 2.0 context menu also doesn't work.

comment:3 Changed 10 years ago by Garry Yao

Keywords: Firefox added
Owner: set to Garry Yao
Status: newassigned

Only reproduceable with FF 2.0.

Changed 10 years ago by Garry Yao

Attachment: 3174.patch added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added

The proposed patch introduce a simply way to fix the urgent issue of raising error, while a more graceful solution could be found later after fixing all other panel frame problem like #3175.

Changed 10 years ago by Garry Yao

Attachment: 3174_2.patch added

comment:5 Changed 10 years ago by Garry Yao

Dedicate the fix to Firefox 2.x.

Changed 10 years ago by Garry Yao

Attachment: 3174_3.patch added

comment:6 Changed 10 years ago by Garry Yao

Fix an IE error.

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Priority: HighNormal

Changed 10 years ago by Martin Kou

Attachment: Picture 7.png added

comment:8 Changed 10 years ago by Martin Kou

The problem also exists on IE7.

comment:9 Changed 10 years ago by Martin Kou

Owner: changed from Garry Yao to Martin Kou
Status: assignednew

comment:10 Changed 10 years ago by Martin Kou

IE7 needs some time to refresh the scrollHeight property of the popup menu's element.

Changed 10 years ago by Martin Kou

Attachment: 3174_4.patch added

comment:11 Changed 10 years ago by Martin Kou

The delay needed in IE7 doesn't seem to have to do with CSS loading - everything from editor.css is already loaded by the time IE7 is trying to open the popup menu.

comment:12 Changed 10 years ago by Garry Yao

Keywords: IE added

More problems were found on IE6:

  1. Sub menu arrow icon was doubled;
  2. Sub menu is broken when too much text of a sub menu item.

comment:13 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Firefox Review? removed

In FF2, it WFM. I'm not sure those fixes are really needed, so if you can confirm it, please remove it from the patch.

It also WFM in IE7, but Martin states that he's still able to randomly reproduce it. So we could even consider a patch just for that.

Changed 10 years ago by Martin Kou

Attachment: Picture 2.png added

comment:14 Changed 10 years ago by Martin Kou

It is still reproducible with today's SVN snapshot. It's a random bug, though.

comment:15 Changed 10 years ago by Martin Kou

I've found the follow method would make the bug easier to reproduce:

  1. Connect to a PC with IE7 or IE8 via Remote Desktop.
  2. Open replacebyclass.html in IE7 or IE8 of the remote machine.
  3. Right click on the "CKEditor" link in the editing area.
  4. If you're lucky, the menu will have a wrong size.
  5. If you're unlucky, refresh the page and try again.

The success rate varies. Sometimes I can have 5 or 6 successes in a row, but other times I can try for something like 40 times and it wouldn't happen once.

Changed 10 years ago by Martin Kou

Attachment: 3174_5.patch added

comment:16 Changed 10 years ago by Martin Kou

Keywords: Review? added; Review- removed

I've stripped away the FF2 part of the fix which is no longer needed.

comment:17 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

i was not able to reproduce it in any way, but it's evident that you have this problem. I'll just trust on your patch.

comment:18 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [3482].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy