Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3176 closed Bug (fixed)

Match the whole word in Find it does not match

Reported by: Aneta Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IBM Cc:

Description

  1. Hit the Find button and type a word from the text.
  1. Tick only - match the whole word and click on Find button.

Result: A notice pops out - The specified text was not found.

Attachments (2)

3176.patch (8.8 KB) - added by Garry Yao 10 years ago.
3176_2.patch (8.3 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Pending added

Are you using a specific browser?

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; Pending removed

Ok, it looks like this problem doesn't happen always. I found a way to reproduce it consistently though:

  1. Load the editor and remove all the text on it.
  1. Manually type three paragraphs, each one containing one of these words, in this order: "test", "try" and "test".
  1. Move the caret to the start of the text.
  1. Open the Find dialog.
  1. In the "Find what" field, type "try" and hit the "Find" button. The word will be correctly found.
  1. Hit "Find" again. A js error is thrown.
  1. Close the dialog.
  1. Repeat steps 3 to 5. It will not work anymore. Actually, the Find dialog will not work anymore until reloading the editor.

Confirmed with FF3.

Changed 10 years ago by Garry Yao

Attachment: 3176.patch added

comment:3 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

The patch improve the logic of characterRange and domRange parts, it also fix a bug in range.js.

Changed 10 years ago by Martin Kou

Attachment: 3176_2.patch added

comment:4 Changed 10 years ago by Martin Kou

Updated Garry's patch with respect to the current trunk for easier reviewing.

comment:5 Changed 10 years ago by Martin Kou

Keywords: Review- added; Review? removed

Review- because the patch doesn't seem to fix the problem described in comment:2. I'm still getting the not found problem when match whole word is ticked.

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review- removed

Verified it been fixed at #3304.

comment:7 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

comment:8 Changed 10 years ago by Martin Kou

Keywords: IBM added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy